CVE-2020-25815: Unescaped message used in HTML within LogEventsList
An issue was discovered in MediaWiki 1.32.x through 1.34.x before 1.34.4. LogEventList::getFiltersDesc is insecurely using message text to build options names for an HTML multi-select field. The relevant code should use escaped() instead of text().
Other sources
Unescaped message used in HTML within LogEventsList
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.31.16-1+deb10u2Fixed in 1:1.31.16-1+deb10u6Fixed in 1:1.35.11-1~deb11u1Fixed in 1:1.35.13-1~deb11u1Fixed in 1:1.39.4-1~deb12u1Fixed in 1:1.39.5-1~deb12u1Fixed in 1:1.39.5-1 - Upgrade
Upgrade
composer/mediawiki/coreto a version that resolves this vulnerability.Fixed in 1.35.0 - Upgrade
Upgrade
composer/mediawiki/coreto a version that resolves this vulnerability.Fixed in 1.34.3
Event History
Frequently Asked Questions
What is the severity of CVE-2020-25815?
CVE-2020-25815 has a medium severity rating due to potential XSS vulnerabilities in MediaWiki.
How do I fix CVE-2020-25815?
To fix CVE-2020-25815, you should upgrade to MediaWiki versions 1.34.4, 1.35.0, or later.
What versions of MediaWiki are affected by CVE-2020-25815?
CVE-2020-25815 affects MediaWiki versions 1.32.x through 1.34.x prior to 1.34.4.
What kind of vulnerability is CVE-2020-25815?
CVE-2020-25815 is classified as a Cross-Site Scripting (XSS) vulnerability due to improper escaping of message text.
Is there a patch available for CVE-2020-25815?
Yes, users can apply the patch by updating to the specified fixed versions of MediaWiki.