CVE-2020-26411: Medium severity GitLab GitLab vulnerability
A potential DOS vulnerability was discovered in all versions of Gitlab starting from 13.4.x (>=13.4 to <13.4.7, >=13.5 to <13.5.5, and >=13.6 to <13.6.2). Using a specific query name for a project search can cause statement timeouts that can lead to a potential DOS if abused.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.4.7 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.5.5 - Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 13.6.2
Event History
Frequently Asked Questions
What is the severity of CVE-2020-26411?
CVE-2020-26411 is classified as a potential denial-of-service (DOS) vulnerability.
How do I fix CVE-2020-26411?
To remediate CVE-2020-26411, upgrade GitLab to versions 13.4.7, 13.5.5, or 13.6.2 or later.
What versions of GitLab are affected by CVE-2020-26411?
CVE-2020-26411 affects GitLab versions from 13.4.0 to 13.4.6, from 13.5.0 to 13.5.4, and from 13.6.0 to 13.6.1.
What triggers the DOS in CVE-2020-26411?
The DOS is triggered by using a specific project search query that can cause statement timeouts.
Is CVE-2020-26411 present in GitLab versions after 13.6.2?
CVE-2020-26411 is not present in GitLab versions published after 13.6.2.