CVE-2020-26541: Infoleak
A flaw was found in the Linux kernel in certs/blacklist.c, When signature entries for EFICERTX509GUID are contained in the Secure Boot Forbidden Signature Database, the entries are skipped. This can cause a security threat and breach system integrity, confidentiality and even lead to a denial of service problem.
Other sources
The Linux kernel through 5.8.13 does not properly enforce the Secure Boot Forbidden Signature Database (aka dbx) protection mechanism. This affects certs/blacklist.c and certs/systemkeyring.c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-305.7.1.rt7.79.el8_4 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-305.7.1.el8_4 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-147.51.1.el8_1 - Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-193.60.2.rt13.112.el8_2 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-193.60.2.el8_2 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2020-26541?
CVE-2020-26541 is classified as a high-severity vulnerability affecting the Linux kernel.
How do I fix CVE-2020-26541?
To fix CVE-2020-26541, upgrade to the recommended kernel versions as listed in the advisory.
Which software versions are affected by CVE-2020-26541?
CVE-2020-26541 affects multiple versions of the Linux kernel, particularly versions up to 5.8.13.
What type of vulnerability is CVE-2020-26541?
CVE-2020-26541 is a kernel vulnerability related to the handling of EFI signature entries affecting system integrity.
Can CVE-2020-26541 lead to system exploitation?
Yes, CVE-2020-26541 can potentially be exploited to breach system integrity, confidentiality, or cause a denial of service.