CVE-2020-28012: High severity Exim Exim vulnerability
Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because rdainterpret uses a privileged pipe that lacks a close-on-exec flag.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/eximto a version that resolves this vulnerability.Fixed in 4.94.2-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2020-28012?
The severity of CVE-2020-28012 is high with a severity value of 7.8.
What is the vulnerability in Exim 4 before 4.94.2?
The vulnerability in Exim 4 before 4.94.2 is the exposure of file descriptor to unintended control sphere.
How does CVE-2020-28012 impact Exim?
CVE-2020-28012 impacts Exim by allowing exposure of file descriptor to unintended control sphere due to a privileged pipe lacking a close-on-exec flag.
Which version of Exim is affected by CVE-2020-28012?
The version of Exim affected by CVE-2020-28012 is between 4.00 and 4.94.1 (excluding 4.94.2).
Is there a fix available for CVE-2020-28012?
Yes, the fix for CVE-2020-28012 is available in Exim version 4.94.2.