CVE-2020-28015: High severity Exim Exim vulnerability
Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the behavior of root processes because a recipient address can have a newline character.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/eximto a version that resolves this vulnerability.Fixed in 4.94.2-r0
Event History
Frequently Asked Questions
What is CVE-2020-28015?
CVE-2020-28015 is a vulnerability in Exim 4 where local users can alter the behavior of root processes due to improper neutralization of line delimiters.
How severe is CVE-2020-28015?
The severity of CVE-2020-28015 is high, with a CVSS score of 7.8.
Which software versions are affected by CVE-2020-28015?
Exim versions between 4.00 and 4.94.2 are affected by CVE-2020-28015.
How can local users exploit CVE-2020-28015?
Local users can exploit CVE-2020-28015 by altering the behavior of root processes using a recipient address with a newline character.
Is there a fix for CVE-2020-28015?
Yes, upgrading to Exim version 4.94.2 or above fixes the CVE-2020-28015 vulnerability.