CVE-2020-28022: Critical severity Exim Exim vulnerability
Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory Buffer. This occurs when processing name=value pairs within MAIL FROM and RCPT TO commands.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/eximto a version that resolves this vulnerability.Fixed in 4.94.2-r0
Event History
Frequently Asked Questions
What is CVE-2020-28022?
CVE-2020-28022 is a vulnerability in Exim 4 before 4.94.2 that allows improper restriction of write operations within the bounds of a memory buffer.
How severe is CVE-2020-28022?
CVE-2020-28022 has a severity score of 9.8, which is classified as critical.
Which software versions are affected by CVE-2020-28022?
Exim versions from 4.00 to 4.94.2 are affected by CVE-2020-28022.
How can I fix CVE-2020-28022?
To fix CVE-2020-28022, you should update Exim to version 4.94.2 or higher.
Where can I find more information about CVE-2020-28022?
You can find more information about CVE-2020-28022 at the following reference: [CVE-2020-28022-EXOPT.txt](https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28022-EXOPT.txt)