CVE-2020-35498: High severity Openvswitch OpenvSwitch vulnerability
A vulnerability was found in openvswitch. A limitation in the implementation of userspace packet parsing can allow a malicious user to send a specially crafted packet causing the resulting megaflow in the kernel to be too wide, potentially causing a denial of service. The highest threat from this vulnerability is to system availability.
Other sources
Due to a limitation in the OVS packet parsing in userspace, the resulting megaflow in the kernel is too wide which can potentially cause a DoS.
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/openvswitch2.11to a version that resolves this vulnerability.Fixed in 0:2.11.3-86.el7fd - Upgrade
Upgrade
redhat/openvswitch2.13to a version that resolves this vulnerability.Fixed in 0:2.13.0-81.el7fd - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 0:2.9.9-1.el7fd - Upgrade
Upgrade
redhat/openvswitch2.13to a version that resolves this vulnerability.Fixed in 0:2.13.0-79.5.el8fd - Upgrade
Upgrade
redhat/openvswitch2.11to a version that resolves this vulnerability.Fixed in 0:2.11.3-83.el8fd - Upgrade
Upgrade
redhat/ovn2.11to a version that resolves this vulnerability.Fixed in 0:2.11.1-57.el7fd - Upgrade
Upgrade
debian/openvswitchto a version that resolves this vulnerability.Fixed in 2.10.7+ds1-0+deb10u1Fixed in 2.10.7+ds1-0+deb10u4Fixed in 2.15.0+ds1-2+deb11u4Fixed in 3.1.0-2Fixed in 3.2.2~git20231029-2 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.5.12 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.6.10 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.7.13 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.8.11 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.9.9 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.10.7 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.11.6 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.12.3 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.13.3 - Upgrade
Upgrade
redhat/openvswitchto a version that resolves this vulnerability.Fixed in 2.14.2 - Upgrade
Upgrade
alpine/openvswitchto a version that resolves this vulnerability.Fixed in 2.12.3-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the vulnerability ID for this openvswitch vulnerability?
The vulnerability ID for this openvswitch vulnerability is CVE-2020-35498.
What is the severity of CVE-2020-35498?
The severity of CVE-2020-35498 is high (7.5).
What is the affected software for CVE-2020-35498?
The affected software for CVE-2020-35498 is openvswitch.
How can a malicious user exploit CVE-2020-35498?
A malicious user can exploit CVE-2020-35498 by sending a specially crafted packet to the openvswitch, causing a denial of service.
Is there a remedy for CVE-2020-35498?
Yes, there is a remedy for CVE-2020-35498. The recommended remedy is to update openvswitch to version 2.5.12 or higher.