CVE-2020-6411: Input Validation
An insufficient validation of untrusted input flaw was found in the Omnibox component of the Chromium browser.
Upstream bug(s):
https://code.google.com/p/chromium/issues/detail?id=929711
External References:
https://chromereleases.googleblog.com/2020/02/stable-channel-update-for-desktop.html
Other sources
Insufficient validation of untrusted input in Omnibox in Google Chrome prior to 80.0.3987.87 allowed a remote attacker to perform domain spoofing via IDN homographs via a crafted domain name.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/chromium-browserto a version that resolves this vulnerability.Fixed in 80.0.3987.87 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
chromium/omniboxto a version that resolves this vulnerability.Fixed in 80.0.3987.87
Event History
Frequently Asked Questions
What is the severity of CVE-2020-6411?
CVE-2020-6411 has been classified as a medium severity vulnerability due to its potential exploitation through untrusted input.
How do I fix CVE-2020-6411?
To resolve CVE-2020-6411, upgrade Chromium to version 80.0.3987.87 or any version higher than that.
Which software is affected by CVE-2020-6411?
CVE-2020-6411 affects Chromium browser versions prior to 80.0.3987.87, as well as Google Chrome versions prior to 80.0.3987.87.
What type of vulnerability is CVE-2020-6411?
CVE-2020-6411 is an insufficient validation of untrusted input flaw categorized under input validation vulnerabilities.
Are there any known exploits for CVE-2020-6411?
As of now, there are no publicly known exploits for CVE-2020-6411, but it is still advised to patch the vulnerability.