CVE-2020-6416: Input Validation
An insufficient data validation flaw was found in the streams component of the Chromium browser.
Upstream bug(s):
https://code.google.com/p/chromium/issues/detail?id=1031895
External References:
https://chromereleases.googleblog.com/2020/02/stable-channel-update-for-desktop.html
Other sources
Insufficient data validation in streams in Google Chrome prior to 80.0.3987.87 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/chromium-browserto a version that resolves this vulnerability.Fixed in 80.0.3987.87 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
chromium/chrometo a version that resolves this vulnerability.Fixed in 80.0.3987.87
Event History
Frequently Asked Questions
What is the severity of CVE-2020-6416?
The severity of CVE-2020-6416 is high with a severity value of 8.8.
How can a remote attacker exploit CVE-2020-6416?
A remote attacker can potentially exploit CVE-2020-6416 by crafting a malicious HTML page.
Which versions of Google Chrome are affected by CVE-2020-6416?
Google Chrome versions prior to 80.0.3987.87 are affected by CVE-2020-6416.
How can I fix CVE-2020-6416?
To fix CVE-2020-6416, update to Google Chrome version 80.0.3987.87 or later.
Where can I find more information about CVE-2020-6416?
You can find more information about CVE-2020-6416 in the following references: [1] [2] [3].