CVE-2020-7776: XSS Vulnerability in HTML Writer

Published Dec 9, 2020
·
Updated

Cross-site scripting in phpoffice/phpspreadsheet

Other sources

This affects the package phpoffice/phpspreadsheet from 0.0.0. The library is vulnerable to XSS when creating an html output from an excel file by adding a comment on any cell. The root cause of this issue is within the HTML writer where user comments are concatenated as part of link and this is returned as HTML. A fix for this issue is available on commit 0ed5b800be2136bcb8fa9c1bdf59abc957a98845/master branch.

— NVD

This affects the package phpoffice/phpspreadsheet. The library is vulnerable to XSS when creating an html output from an excel file by adding a comment on any cell. The root cause of this issue is within the HTML writer where user comments are concatenated as part of link and this is returned as HTML.

— GitHub

Affected Software

7 affected componentsFixes available
composer/phpoffice/phpspreadsheet<1.16.0
PHPOffice phpspreadsheet<1.16.0
Phpspreadsheet Project Phpspreadsheet<1.16.0
composer/phpoffice/phpexcel<=1.8.2
composer/phpoffice/phpspreadsheet<1.16.0
1.16.0
composer/phpoffice/phpspreadsheet<1.16.0
1.16.0
composer/phpoffice/phpexcel<=1.8.2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/phpoffice/phpspreadsheet to a version that resolves this vulnerability.

    Fixed in 1.16.0
  2. Upgrade

    Upgrade phpoffice/phpspreadsheet to a version that resolves this vulnerability.

    Patch 0ed5b800be2136bcb8fa9c1bdf59abc957a98845/master

Event History

Dec 9, 2020
CVE Published
via MITRE·04:45 PM
Data Sourced
via MITRE·04:45 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Dec 31, 2020
Advisory Published
07:20 PM
Data Sourced
via Packagist·07:20 PM
DescriptionSeverityAffected Software
May 6, 2021
Advisory Published
via GitHub·06:53 PM
Data Sourced
via GitHub·06:53 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2020-7776?

The severity of CVE-2020-7776 is classified as medium due to its potential for cross-site scripting (XSS) attacks.

2

How do I fix CVE-2020-7776?

To fix CVE-2020-7776, upgrade the phpoffice/phpspreadsheet package to version 1.16.0 or later.

3

What type of vulnerability is CVE-2020-7776?

CVE-2020-7776 is a cross-site scripting (XSS) vulnerability found in the phpoffice/phpspreadsheet library.

4

In which versions of phpoffice/phpspreadsheet is CVE-2020-7776 present?

CVE-2020-7776 is present in phpoffice/phpspreadsheet versions prior to 1.16.0.

5

Who is affected by CVE-2020-7776?

Users of phpoffice/phpspreadsheet version 1.16.0 and below are affected by CVE-2020-7776.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203