CVE-2020-8172: TLS session reuse can lead to host certificate verification bypass

Published Jun 2, 2020
·
Updated

A TLS Hostname verification bypass vulnerability exists in NodeJS. This flaw allows an attacker to bypass TLS Hostname verification when a TLS client reuses HTTPS sessions.

Other sources

The 'session' event could be emitted before the 'secureConnect' event. It should not be, because the connection may fail to be authorized. If it was saved an authorized connection could be established later with the session ticket. Note that the https agent caches sessions, so is vulnerable to this.

The 'session' event will now only be emitted after the 'secureConnect' event, and only for authorized connections.

Does not affect Node.js 10.x.

— Node.Js

TLS session reuse can lead to host certificate verification bypass in node version < 12.18.0 and < 14.4.0.

Affected Software

46 affected componentsFixes available
redhat/rh-nodejs12-nodejs<0:12.18.2-1.el7
0:12.18.2-1.el7
debian/nodejs
10.24.0~dfsg-1~deb10u110.24.0~dfsg-1~deb10u312.22.12~dfsg-1~deb11u418.13.0+dfsg1-1
redhat/nodejs<12.18.0
12.18.0
redhat/nodejs<14.4.0
14.4.0
Nodejs Node.js>=12.0.0<12.18.0
Nodejs Node.js>=14.0.0<14.4.0
Oracle Banking Extensibility Workbench=14.3.0
Oracle Banking Extensibility Workbench=14.4.0
Oracle Blockchain Platform<21.1.2
Oracle GraalVM=19.3.2
Oracle GraalVM=20.1.0
Oracle MySQL Cluster<=7.3.30
Oracle MySQL Cluster>=7.4.0<=7.4.29
Oracle MySQL Cluster>=7.5.0<=7.5.19
Oracle MySQL Cluster>=7.6.0<=7.6.15
Oracle MySQL Cluster>=8.0.0<=8.0.21
Node.js Node.js>=12.0.0<12.18.0, >=14.0.0<14.4.0
12.18.014.4.0
Node.js Node.js>=12.0.0<12.18.0
12.18.0
Node.js Node.js>=14.0.0<14.4.0
14.4.0
alpine/nodejs<12.20.1-r0
12.20.1-r0
alpine/nodejs<12.18.3-r0
12.18.3-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs<12.18.0-r0
12.18.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0
alpine/nodejs-current<14.4.0-r0
14.4.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/rh-nodejs12-nodejs to a version that resolves this vulnerability.

    Fixed in 0:12.18.2-1.el7
  2. Upgrade

    Upgrade debian/nodejs to a version that resolves this vulnerability.

    Fixed in 10.24.0~dfsg-1~deb10u1Fixed in 10.24.0~dfsg-1~deb10u3Fixed in 12.22.12~dfsg-1~deb11u4Fixed in 18.13.0+dfsg1-1
  3. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 12.18.0
  4. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 14.4.0
  5. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.18.0Fixed in 14.4.0
  6. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.18.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 14.4.0
  8. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 12.20.1-r0
  9. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 12.18.3-r0
  10. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 12.18.0-r0
  11. Upgrade

    Upgrade alpine/nodejs-current to a version that resolves this vulnerability.

    Fixed in 14.4.0-r0
  12. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 12.18.0
  13. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 14.4.0

Event History

Jun 2, 2020
CVE Published
12:00 AM
Data Sourced
via Node.js·12:00 PM
DescriptionSeverityAffected Software
Jun 8, 2020
CVE Published
via MITRE·01:08 PM
Data Sourced
via MITRE·01:08 PM
DescriptionWeakness
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203