CVE-2020-8277: Denial of Service through DNS request
A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of service by getting the application to resolve a DNS record with a larger number of responses.
Versions 12.16.3 and higher on the 12.x release line
Versions 14.13.0 and higher on the 14.x release line
All versions of the 15.x release line
Other sources
A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.
Denial of Service through DNS request (High). A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service by getting the application to resolve a DNS record with a larger number of responses.
Reference: https://github.com/c-ares/c-ares/issues/371
Upstream patch: https://github.com/c-ares/c-ares/commit/0d252eb3b2147179296a3bdb4ef97883c97c54d3
— Red Hat
Node.js is vulnerable to a denial of service. By getting the application to resolve a DNS record with a larger number of responses, an attacker could exploit this vulnerability to trigger a DNS request for a host of their choice resulting in a denial of service.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/rh-nodejs12-nodejsto a version that resolves this vulnerability.Fixed in 0:12.19.1-2.el7 - Upgrade
Upgrade
redhat/rh-nodejs14-nodejsto a version that resolves this vulnerability.Fixed in 0:14.15.4-2.el7 - Upgrade
Upgrade
redhat/c-aresto a version that resolves this vulnerability.Fixed in 1.17.0 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 12.19.1Fixed in 14.15.1Fixed in 15.2.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 12.19.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 14.15.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 15.2.1 - Upgrade
Upgrade
alpine/nodejsto a version that resolves this vulnerability.Fixed in 12.20.1-r0 - Upgrade
Upgrade
alpine/nodejsto a version that resolves this vulnerability.Fixed in 14.15.1-r0 - Upgrade
Upgrade
alpine/nodejs-currentto a version that resolves this vulnerability.Fixed in 15.3.0-r0 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 15.2.1 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 14.15.1 - Upgrade
Upgrade
Node.jsto a version that resolves this vulnerability.Fixed in 12.19.1
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is CVE-2020-8277?
CVE-2020-8277 is a vulnerability in Node.js that allows an attacker to trigger a Denial of Service by getting the application to resolve a DNS record with a larger number of responses.
Which versions of Node.js are affected by CVE-2020-8277?
Versions < 15.2.1, < 14.15.1, and < 12.19.1 of Node.js are affected by CVE-2020-8277.
How can I fix CVE-2020-8277?
To fix CVE-2020-8277, update your Node.js installation to version 15.2.1, 14.15.1, or 12.19.1 or higher.
What is the severity of CVE-2020-8277?
CVE-2020-8277 has a severity of 7.5 (high).
Where can I find more information about CVE-2020-8277?
More information about CVE-2020-8277 can be found on the GitHub page and the Red Hat Bugzilla page.