CVE-2021-20321: Race Condition
A race condition accessing file object in the Linux kernel OverlayFS subsystem was found in the way users do rename in specific way with OverlayFS. A local user could use this flaw to crash the system.
Other sources
An attacker with a low-privileged user on a Linux machine with an overlay mount can escalate his privileges up to root when performing rename in specific way with this overlayfs.
Reference: a295aef603e1 ("ovl: fix missing negative dentry check in ovlrename()")
— Red Hat
In ovlrename of dir.c, there is a possible out of bounds write due to a race condition. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.
— OSV
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.15 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
android/:linux_kernel:to a version that resolves this vulnerability.Fixed in :2022-06-05 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch a295aef603e1
Event History
Frequently Asked Questions
What is the severity of CVE-2021-20321?
CVE-2021-20321 is considered a high-severity vulnerability due to its potential to allow local privilege escalation and system crashes.
How do I fix CVE-2021-20321?
To fix CVE-2021-20321, update your Linux kernel to version 5.15 or later for Red Hat or to the specified patched versions for Debian.
Who is affected by CVE-2021-20321?
CVE-2021-20321 affects users who have low privileges on Linux machines specifically using the OverlayFS feature.
Can CVE-2021-20321 cause data loss?
While CVE-2021-20321 primarily enables system crashes, it does not directly lead to data loss but can disrupt system operations significantly.
What systems are vulnerable to CVE-2021-20321?
Vulnerable systems include those running specific versions of the Linux kernel, particularly versions prior to 5.15.