CVE-2021-2154: Medium severity Oracle MySQL vulnerability
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.7.33 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server.
External References:
https://www.oracle.com/security-alerts/cpuapr2021.html#AppendixMSQL
Other sources
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.7.33 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/mysqlto a version that resolves this vulnerability.Fixed in 5.7.34 - Upgrade
Upgrade
redhat/mariadbto a version that resolves this vulnerability.Fixed in 10.5.10 - Upgrade
Upgrade
redhat/mariadbto a version that resolves this vulnerability.Fixed in 10.4.19 - Upgrade
Upgrade
redhat/mariadbto a version that resolves this vulnerability.Fixed in 10.3.29 - Upgrade
Upgrade
redhat/mariadbto a version that resolves this vulnerability.Fixed in 10.2.38
Event History
Frequently Asked Questions
What is the severity of CVE-2021-2154?
CVE-2021-2154 is classified as an easily exploitable high severity vulnerability in MySQL Server.
How do I fix CVE-2021-2154?
To remediate CVE-2021-2154, upgrade to MySQL Server version 5.7.34 or later.
What versions are affected by CVE-2021-2154?
The affected versions by CVE-2021-2154 are MySQL Server 5.7.33 and earlier.
Who is affected by CVE-2021-2154?
Any organization using MySQL Server version 5.7.33 or earlier is at risk due to CVE-2021-2154.
What types of attacks can occur due to CVE-2021-2154?
CVE-2021-2154 allows a high privileged attacker with network access to potentially compromise MySQL Server.