CVE-2021-22179: SSRF
A vulnerability was discovered in GitLab versions before 12.2. GitLab was vulnerable to a SSRF attack through the Outbound Requests feature.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
GitLabto a version that resolves this vulnerability.Fixed in 12.2
Event History
Frequently Asked Questions
What is the severity of CVE-2021-22179?
CVE-2021-22179 has been assigned a medium severity rating due to its potential to allow server-side request forgery (SSRF) attacks.
How do I fix CVE-2021-22179?
To fix CVE-2021-22179, upgrade GitLab to version 12.2.0 or later, specifically to a version greater than 13.6.6.
Which versions of GitLab are affected by CVE-2021-22179?
CVE-2021-22179 affects GitLab versions from 12.2.0 up to and including 13.6.6.
What type of attack does CVE-2021-22179 allow?
CVE-2021-22179 allows for server-side request forgery (SSRF) attacks through the Outbound Requests feature.
Is CVE-2021-22179 applicable to both community and enterprise editions?
Yes, CVE-2021-22179 affects both the community and enterprise editions of GitLab.