CVE-2021-22217: Medium severity GitLab GitLab vulnerability
Published Jun 8, 2021
·Updated
A denial of service vulnerability in all versions of GitLab CE/EE before 13.12.2, 13.11.5 or 13.10.5 allows an attacker to cause uncontrolled resource consumption with a specially crafted issue or merge request
Affected Software
6 affected components
GitLab GitLab<13.10.5
GitLab GitLab<13.10.5
GitLab GitLab>=13.11<13.11.5
GitLab GitLab>=13.11<13.11.5
GitLab GitLab>=13.12<13.12.2
GitLab GitLab>=13.12<13.12.2
Event History
Jun 8, 2021
CVE Published
via MITRE·06:25 PM
Data Sourced
via MITRE·06:25 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·07:15 PM
DescriptionSeverity
Frequently Asked Questions
1
What is the severity of CVE-2021-22217?
CVE-2021-22217 is classified as a denial of service vulnerability, allowing for uncontrolled resource consumption.
2
How do I fix CVE-2021-22217?
To fix CVE-2021-22217, upgrade to GitLab CE/EE version 13.12.2, 13.11.5, or 13.10.5 or later.
3
Which versions of GitLab are affected by CVE-2021-22217?
CVE-2021-22217 affects all versions of GitLab CE/EE before 13.12.2, 13.11.5, or 13.10.5.
4
What type of attack is associated with CVE-2021-22217?
CVE-2021-22217 is associated with denial of service attacks, specifically through crafted issues or merge requests.
5
Can CVE-2021-22217 be exploited remotely?
Yes, CVE-2021-22217 can be exploited remotely by an attacker using specially crafted issues or merge requests.