CVE-2021-22930: Use after free on close http2 on stream canceling

Published Jul 29, 2021
·
Updated

A flaw was found in Node.js, where it is vulnerable to a use-after-free attack. This flaw allows an attacker to exploit the memory corruption, which causes a change in the process behavior. The highest threat from this vulnerability is to confidentiality and integrity.

Other sources

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Node.js before is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior. You can read more about it in https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22930

— Node.Js

Node.js could allow a remote attacker to bypass security restrictions, caused by a use-after-free on close http2 on stream canceling. An attacker could exploit this vulnerability to corrupt memory to change process behavior.

— IBM

Node.js is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Reference: https://nodejs.org/en/blog/vulnerability/july-2021-security-releases-2/

— Red Hat

Node.js is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

You can read more about it in https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22930

All versions of the 16.x, 14.x, and 12.x releases lines

— Node.Js

Affected Software

46 affected componentsFixes available
redhat/rh-nodejs14-nodejs<0:14.17.5-1.el7
0:14.17.5-1.el7
redhat/rh-nodejs12-nodejs<0:12.22.5-1.el7
0:12.22.5-1.el7
redhat/rh-nodejs12-nodejs-nodemon<0:2.0.3-5.el7
0:2.0.3-5.el7
redhat/nodejs<12.22.4
12.22.4
redhat/nodejs<14.17.4
14.17.4
redhat/nodejs<16.6.0
16.6.0
IBM Cognos Controller<=11.0.0 - 11.0.1
Nodejs Node.js>=12.0.0<12.22.4
Nodejs Node.js>=14.0.0<14.17.4
Nodejs Node.js>=16.0.0<16.6.0
NetApp Nextgen Api
Siemens Sinec Infrastructure Network Services<1.0.1.1
Debian Debian Linux=10.0
Node.js Node.js>=12.0.0<12.22.4, >=14.0.0<14.17.4, >=16.0.0<16.6.0
12.22.414.17.416.6.0
Node.js Node.js>=12.0.0<12.22.4
12.22.4
Node.js Node.js>=12.0.0<12.22.5
12.22.5
Node.js Node.js>=14.0.0<14.17.5
14.17.5
Node.js Node.js>=14.0.0<14.17.4
14.17.4
Node.js Node.js>=16.0.0<16.6.2
16.6.2
Node.js Node.js>=16.0.0<16.6.0
16.6.0
alpine/nodejs<12.22.4-r0
12.22.4-r0
alpine/nodejs<12.22.4-r0
12.22.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs<14.17.4-r0
14.17.4-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
alpine/nodejs-current<16.6.0-r0
16.6.0-r0
ubuntu/nodejs*

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/rh-nodejs14-nodejs to a version that resolves this vulnerability.

    Fixed in 0:14.17.5-1.el7
  2. Upgrade

    Upgrade redhat/rh-nodejs12-nodejs to a version that resolves this vulnerability.

    Fixed in 0:12.22.5-1.el7
  3. Upgrade

    Upgrade redhat/rh-nodejs12-nodejs-nodemon to a version that resolves this vulnerability.

    Fixed in 0:2.0.3-5.el7
  4. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 12.22.4
  5. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 14.17.4
  6. Upgrade

    Upgrade redhat/nodejs to a version that resolves this vulnerability.

    Fixed in 16.6.0
  7. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.22.4Fixed in 14.17.4Fixed in 16.6.0
  8. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.22.4
  9. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.22.5
  10. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 14.17.5
  11. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 14.17.4
  12. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 16.6.2
  13. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 16.6.0
  14. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 12.22.4-r0
  15. Upgrade

    Upgrade alpine/nodejs to a version that resolves this vulnerability.

    Fixed in 14.17.4-r0
  16. Upgrade

    Upgrade alpine/nodejs-current to a version that resolves this vulnerability.

    Fixed in 16.6.0-r0
  17. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 16.6.0
  18. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 14.17.4
  19. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 12.22.4

Event History

Jul 29, 2021
CVE Published
12:00 AM
Data Sourced
via Node.js·04:00 PM
DescriptionSeverity
Data Sourced
via Node.js·04:51 PM
Affected Software
Oct 7, 2021
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
DescriptionWeakness
Data Sourced
via OSV·02:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Nov 4, 2026
Withdrawn
via OSV·04:43 PM

Frequently Asked Questions

1

What is CVE-2021-22930?

CVE-2021-22930 is a vulnerability in Node.js that allows for a use-after-free attack, leading to memory corruption and a change in process behavior.

2

What is the severity of CVE-2021-22930?

CVE-2021-22930 has a severity rating of critical, with a severity value of 9.

3

What software versions are affected by CVE-2021-22930?

Versions before Node.js 16.6.0, 14.17.4, and 12.22.4 are affected by CVE-2021-22930.

4

How can I fix CVE-2021-22930?

To fix CVE-2021-22930, update to Node.js versions 16.6.0, 14.17.4, or 12.22.4.

5

What is a use-after-free attack?

A use-after-free attack is a type of memory corruption attack where an attacker manipulates object references after they have been freed, leading to unintended behavior and potential exploitation.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203