CVE-2021-2308: Low severity Oracle MySQL vulnerability
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Information Schema). Supported versions that are affected are 8.0.23 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Server accessible data.
External References:
https://www.oracle.com/security-alerts/cpuapr2021.html#AppendixMSQL
Other sources
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Information Schema). Supported versions that are affected are 8.0.23 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized read access to a subset of MySQL Server accessible data. CVSS 3.1 Base Score 2.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N).
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/mysqlto a version that resolves this vulnerability.Fixed in 8.0.24
Event History
Frequently Asked Questions
What is the severity of CVE-2021-2308?
CVE-2021-2308 is rated as a high severity vulnerability due to its potential for exploitation by high privileged attackers.
How do I fix CVE-2021-2308?
To fix CVE-2021-2308, upgrade to MySQL Server version 8.0.24 or later.
Which MySQL versions are affected by CVE-2021-2308?
CVE-2021-2308 affects MySQL Server versions 8.0.23 and earlier.
What types of attackers can exploit CVE-2021-2308?
CVE-2021-2308 can be exploited by high privileged attackers with network access.
What components of MySQL are affected by CVE-2021-2308?
CVE-2021-2308 affects the Server component specifically related to the Information Schema.