CVE-2021-2340: Low severity Oracle MySQL vulnerability
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Memcached). Supported versions that are affected are 8.0.25 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server.
External References:
http://www.oracle.com/security-alerts/cpujul2021.html#AppendixMSQL
Other sources
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Memcached). Supported versions that are affected are 8.0.25 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. CVSS 3.1 Base Score 2.7 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L).
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/mysqlto a version that resolves this vulnerability.Fixed in 8.0.26
Event History
Frequently Asked Questions
What is the severity of CVE-2021-2340?
CVE-2021-2340 is rated as a high-severity vulnerability due to its potential for exploitation by high-privileged attackers.
How do I fix CVE-2021-2340?
To fix CVE-2021-2340, upgrade your MySQL Server to version 8.0.26 or later.
Who is affected by CVE-2021-2340?
CVE-2021-2340 affects MySQL Server versions 8.0.25 and prior, including various distributions like Fedora and Red Hat.
What component does CVE-2021-2340 affect?
CVE-2021-2340 affects the Memcached component of the MySQL Server product.
Can CVE-2021-2340 be exploited remotely?
Yes, CVE-2021-2340 can be exploited remotely by attackers with network access through multiple protocols.