CVE-2021-25287: Critical severity Python Pillow vulnerability

Published Apr 1, 2021
·
Updated

An issue was discovered in Pillow before 8.2.0. There is an out-of-bounds read in J2kDecode, in j2kugrayala.

Other sources

There is an out-of-bounds read in J2kDecode in j2kugrayala. For J2k images with multiple bands, it’s legal to have different widths for each band, e.g. 1 byte for L, 4 bytes for A.

Affected Software

16 affected componentsFixes available
redhat/python-pillow<0:5.1.1-16.el8
0:5.1.1-16.el8
redhat/python-pillow<8.2.0
8.2.0
pip/pillow>=2.4.0<8.2.0
8.2.0
Python Pillow<8.2.0
Fedoraproject Fedora=33
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0
alpine/py3-pillow<8.2.0-r0
8.2.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/python-pillow to a version that resolves this vulnerability.

    Fixed in 0:5.1.1-16.el8
  2. Upgrade

    Upgrade redhat/python-pillow to a version that resolves this vulnerability.

    Fixed in 8.2.0
  3. Upgrade

    Upgrade pip/Pillow to a version that resolves this vulnerability.

    Fixed in 8.2.0
  4. Upgrade

    Upgrade Pillow to a version that resolves this vulnerability.

    Fixed in 8.2.0
  5. Configuration

    Keep the invoice generation feature disabled.

    Red Hat Quay invoice generation = disabled

Event History

Apr 1, 2021
CVE Published
12:00 AM
Jun 2, 2021
CVE Published
via MITRE·03:13 PM
Data Sourced
via MITRE·03:13 PM
Description
Data Sourced
via NVD·04:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software
Jun 8, 2021
Advisory Published
via GitHub·06:49 PM

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID?

The vulnerability ID is CVE-2021-25287.

2

What is the severity of CVE-2021-25287?

The severity of CVE-2021-25287 is critical with a CVSS score of 9.1.

3

What is the affected software?

The affected software includes Python Pillow versions up to and excluding 8.2.0, and Python Pillow version 0:5.1.1-16.el8 on Red Hat Enterprise Linux 8.

4

How can I fix CVE-2021-25287?

To fix CVE-2021-25287, you should update to version 8.2.0 of Python Pillow.

5

Where can I find more information about CVE-2021-25287?

You can find more information about CVE-2021-25287 on the following references: [https://pillow.readthedocs.io/en/stable/releasenotes/8.2.0.html#security](https://pillow.readthedocs.io/en/stable/releasenotes/8.2.0.html#security), [https://github.com/python-pillow/Pillow/pull/5377](https://github.com/python-pillow/Pillow/pull/5377), [https://bugzilla.redhat.com/show_bug.cgi/show_bug.cgi?id=1958230](https://bugzilla.redhat.com/show_bug.cgi/show_bug.cgi?id=1958230).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203