CVE-2021-26675: Buffer Overflow

Published Feb 9, 2021
·
Updated

A stack-based buffer overflow in dnsproxy in ConnMan before 1.39 could be used by network adjacent attackers to execute code.

Affected Software

20 affected componentsFixes available
ubuntu/connman<1.36-2.1
1.36-2.1
ubuntu/connman<1.35-6ubuntu0.1~
1.35-6ubuntu0.1~
ubuntu/connman<1.36-2ubuntu0.1
1.36-2ubuntu0.1
debian/connman
1.36-2.1~deb10u21.36-2.1~deb10u51.36-2.2+deb11u21.41-31.42-5
Intel Connman<1.39
Debian Debian Linux=9.0
Debian Debian Linux=10.0
openSUSE Leap=15.2
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0
alpine/connman<1.39-r0
1.39-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.1
  2. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.35-6ubuntu0.1~
  3. Upgrade

    Upgrade ubuntu/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2ubuntu0.1
  4. Upgrade

    Upgrade debian/connman to a version that resolves this vulnerability.

    Fixed in 1.36-2.1~deb10u2Fixed in 1.36-2.1~deb10u5Fixed in 1.36-2.2+deb11u2Fixed in 1.41-3Fixed in 1.42-5
  5. Upgrade

    Upgrade alpine/connman to a version that resolves this vulnerability.

    Fixed in 1.39-r0

Event History

Feb 9, 2021
CVE Published
via Ubuntu·12:00 AM
CVE Published
via MITRE·03:47 PM
Data Sourced
via MITRE·03:47 PM
Description
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID?

The vulnerability ID is CVE-2021-26675.

2

What is the severity of CVE-2021-26675?

The severity of CVE-2021-26675 is high, with a severity value of 8.8.

3

What is the affected software?

The affected software is ConnMan versions 1.36-2.1 and earlier.

4

How can network adjacent attackers exploit CVE-2021-26675?

Network adjacent attackers can exploit CVE-2021-26675 to execute code by triggering a stack-based buffer overflow in dnsproxy.

5

Where can I find more information about CVE-2021-26675?

You can find more information about CVE-2021-26675 at the following references: [link-1], [link-2], [link-3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203