CVE-2021-26676: Medium severity Intel Connman vulnerability
gdhcp in ConnMan before 1.39 could be used by network-adjacent attackers to leak sensitive stack information, allowing further exploitation of bugs in gdhcp.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/connmanto a version that resolves this vulnerability.Fixed in 1.36-2.1 - Upgrade
Upgrade
ubuntu/connmanto a version that resolves this vulnerability.Fixed in 1.21-1.2+ - Upgrade
Upgrade
ubuntu/connmanto a version that resolves this vulnerability.Fixed in 1.35-6ubuntu0.1~ - Upgrade
Upgrade
ubuntu/connmanto a version that resolves this vulnerability.Fixed in 1.36-2ubuntu0.1 - Upgrade
Upgrade
debian/connmanto a version that resolves this vulnerability.Fixed in 1.36-2.1~deb10u2Fixed in 1.36-2.1~deb10u5Fixed in 1.36-2.2+deb11u2Fixed in 1.41-3Fixed in 1.42-5 - Upgrade
Upgrade
alpine/connmanto a version that resolves this vulnerability.Fixed in 1.38-r4 - Upgrade
Upgrade
alpine/connmanto a version that resolves this vulnerability.Fixed in 1.39-r0
Event History
Frequently Asked Questions
What is CVE-2021-26676?
CVE-2021-26676 is a vulnerability in gdhcp in ConnMan before version 1.39 that could be used by network-adjacent attackers to leak sensitive stack information.
How can CVE-2021-26676 be exploited?
CVE-2021-26676 can be exploited by network-adjacent attackers to leak sensitive stack information, which can then be used to further exploit bugs in gdhcp.
Which software versions are affected by CVE-2021-26676?
ConnMan versions before 1.39 are affected by CVE-2021-26676.
What is the remedy for CVE-2021-26676 in Debian?
For Debian, updating to ConnMan version 1.41-3 or higher will remedy CVE-2021-26676.
What is the remedy for CVE-2021-26676 in Ubuntu?
The remedy for CVE-2021-26676 in Ubuntu depends on the specific version. Please refer to the provided references for more information.