CVE-2021-30558: Insufficient policy enforcement in content security policy
Insufficient policy enforcement in content security policy in Google Chrome prior to 91.0.4472.77 allowed a remote attacker to bypass content security policy via a crafted HTML page. (Chrome security severity: Medium)
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 91.0.4472.77 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
- CVE-2021-30521
- CVE-2021-30522
- CVE-2021-30523
- CVE-2021-30524
- CVE-2021-30525
- CVE-2021-30526
- CVE-2021-30527
- CVE-2021-30528
- CVE-2021-4322
- CVE-2021-30529
- CVE-2021-30530
- CVE-2021-30531
- CVE-2021-30532
- CVE-2021-30533
- CVE-2021-30534
- CVE-2021-30535
- CVE-2021-30542
- CVE-2021-30543
- CVE-2021-30536
- CVE-2021-30537
- CVE-2021-30538
- CVE-2021-30539
- CVE-2021-30540
- CVE-2021-4321
Frequently Asked Questions
What is the severity of CVE-2021-30558?
The severity of CVE-2021-30558 is classified as Medium.
How do I fix CVE-2021-30558?
To fix CVE-2021-30558, update Google Chrome to version 91.0.4472.77 or later.
What is the impact of CVE-2021-30558?
CVE-2021-30558 could allow a remote attacker to bypass content security policies via a crafted HTML page.
Which versions of Google Chrome are affected by CVE-2021-30558?
Google Chrome versions prior to 91.0.4472.77 are affected by CVE-2021-30558.
Is CVE-2021-30558 a browser vulnerability?
Yes, CVE-2021-30558 is a vulnerability found in the Google Chrome web browser.