CVE-2021-30587: Inappropriate implementation in Compositing on Windows

Published Apr 30, 2021
·
Updated

Inappropriate implementation in Compositing in Google Chrome prior to 92.0.4515.107 allowed a remote attacker to potentially spoof the contents of the Omnibox (URL bar) via a crafted HTML page.

Credit

Abdulrahman Alqabandi, Microsoft Browser Vulnerability Research

Affected Software

26 affected componentsFixes available
Google Chrome<92.0.4515.107
92.0.4515.107
Google Chrome<92.0.4515.107
Fedoraproject Fedora=33
Fedoraproject Fedora=34
Fedoraproject Fedora=35
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/chromium<92.0.4515.107-r0
92.0.4515.107-r0
alpine/qt5-qtwebengine<5.15.3_git20211006-r0
5.15.3_git20211006-r0
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5
alpine/qt5-qtwebengine<5.15.3_git20210510-r5
5.15.3_git20210510-r5

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 92.0.4515.107
  2. Upgrade

    Upgrade alpine/chromium to a version that resolves this vulnerability.

    Fixed in 92.0.4515.107-r0
  3. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211006-r0
  4. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20210510-r5

Event History

Apr 30, 2021
CVE Published
12:00 AM
Aug 3, 2021
CVE Published
via MITRE·07:41 PM
Data Sourced
via MITRE·07:41 PM
DescriptionWeakness
Data Sourced
via NVD·08:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2021-30587?

CVE-2021-30587 is a vulnerability in the Compositing implementation in Google Chrome prior to version 92.0.4515.107.

2

How does CVE-2021-30587 impact Google Chrome?

CVE-2021-30587 allows a remote attacker to potentially spoof the contents of the Omnibox (URL bar) by using a crafted HTML page.

3

Which versions of Google Chrome are affected by CVE-2021-30587?

Google Chrome versions prior to 92.0.4515.107 are affected by CVE-2021-30587.

4

What is the severity of CVE-2021-30587?

CVE-2021-30587 has a severity rating of medium with a CVSS score of 4.3.

5

How can I fix the CVE-2021-30587 vulnerability in Google Chrome?

To fix the CVE-2021-30587 vulnerability, update Google Chrome to version 92.0.4515.107 or later.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203