CVE-2021-32055: Critical severity Mutt Mutt vulnerability

Published May 5, 2021
·
Updated

Last updated 16 January 2025

Other sources

Mutt 1.11.0 through 2.0.x before 2.0.7 (and NeoMutt 2019-10-25 through 2021-05-04) has a $imapqresync issue in which imap/util.c has an out-of-bounds read in situations where an IMAP sequence set ends with a comma. NOTE: the $imapqresync setting for QRESYNC is not enabled by default.

Affected Software

12 affected componentsFixes available
Mutt Mutt>=1.11.0<2.0.7
neomutt neomutt>=20191025<=20210504
debian/mutt
2.0.5-4.1+deb11u32.2.12-0.1~deb12u12.2.9-1+deb12u12.2.13-1
debian/neomutt
20201127+dfsg.1-1.220220429+dfsg1-4.120250404+dfsg-2
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0
alpine/neomutt>=20191025<20211015-r0
20211015-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/mutt to a version that resolves this vulnerability.

    Fixed in 2.0.5-4.1+deb11u3Fixed in 2.2.12-0.1~deb12u1Fixed in 2.2.9-1+deb12u1Fixed in 2.2.13-1
  2. Upgrade

    Upgrade debian/neomutt to a version that resolves this vulnerability.

    Fixed in 20201127+dfsg.1-1.2Fixed in 20220429+dfsg1-4.1Fixed in 20250404+dfsg-2
  3. Upgrade

    Upgrade alpine/neomutt to a version that resolves this vulnerability.

    Fixed in 20211015-r0
  4. Upgrade

    Upgrade Mutt to a version that resolves this vulnerability.

    Fixed in 2.0.7

Event History

May 5, 2021
CVE Published
via MITRE·03:06 PM
Data Sourced
via MITRE·03:06 PM
Description
Data Sourced
via NVD·04:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·04:15 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2021-32055?

CVE-2021-32055 is a vulnerability in Mutt and NeoMutt which allows for an out-of-bounds read due to a $imap_qresync issue.

2

How severe is CVE-2021-32055?

CVE-2021-32055 has a severity value of 9.1, which is considered critical.

3

Which software versions are affected by CVE-2021-32055?

Mutt versions 1.11.0 through 2.0.x (before 2.0.7) and NeoMutt versions 2019-10-25 through 2021-05-04 are affected by CVE-2021-32055.

4

How can I fix CVE-2021-32055?

To fix CVE-2021-32055, upgrade to Mutt version 2.0.7 or later, or upgrade to a later version of NeoMutt after 2021-05-04.

5

Where can I find more information about CVE-2021-32055?

For more information about CVE-2021-32055, you can refer to the following references: [Link 1](http://lists.mutt.org/pipermail/mutt-announce/Week-of-Mon-20210503/000036.html), [Link 2](https://github.com/neomutt/neomutt/commit/fa1db5785e5cfd9d3cd27b7571b9fe268d2ec2dc), [Link 3](https://gitlab.com/muttmua/mutt/-/commit/7c4779ac24d2fb68a2a47b58c7904118f40965d5).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203