CVE-2021-32478: Moodle reflected XSS
Moodle reflected XSS
Other sources
The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.8.9 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.9.7 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 3.10.4 - Compensating control
Apply extra sanitizing to the redirect URI in the LTI authorization endpoint to prevent reflected XSS and open redirect risks.
Event History
Frequently Asked Questions
What is the severity of CVE-2021-32478?
The severity of CVE-2021-32478 is medium with a severity value of 6.1.
What is the affected software for CVE-2021-32478?
The affected software for CVE-2021-32478 is Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions.
What are the risks associated with CVE-2021-32478?
CVE-2021-32478 poses risks of reflected XSS and open redirect.
How can I fix CVE-2021-32478?
To fix CVE-2021-32478, upgrade to Moodle versions 3.10.4, 3.9.7, or 3.8.9 or apply the necessary patches provided by Moodle.
Where can I find more information about CVE-2021-32478?
You can find more information about CVE-2021-32478 at: https://moodle.org/mod/forum/discuss.php?d=422314