CVE-2021-32711: Exposure of Sensitive Information to an Unauthorized Actor
Exposure of Sensitive Information to an Unauthorized Actor
Other sources
Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/shopware/platformto a version that resolves this vulnerability.Fixed in 6.3.5.1 - Upgrade
Upgrade
Shopwareto a version that resolves this vulnerability.Fixed in 6.3.5.1
Event History
Frequently Asked Questions
What is CVE-2021-32711?
CVE-2021-32711 is a vulnerability in the Shopware eCommerce platform that allows for information leakage via the Store-API.
How severe is CVE-2021-32711?
CVE-2021-32711 has a severity score of 7.5, indicating a critical vulnerability.
Which versions of Shopware are affected by CVE-2021-32711?
Versions of Shopware prior to 6.3.5.1 are affected by CVE-2021-32711.
How can CVE-2021-32711 be fixed?
CVE-2021-32711 can be fixed by updating to version 6.3.5.1 or later of the Shopware platform, which includes a non-backward-compatible change to address the vulnerability.
Who is affected by CVE-2021-32711?
Only consumers of the Store-API in Shopware are affected by CVE-2021-32711.