CVE-2021-37707: Manipulation of product reviews via API

Published Aug 16, 2021
·
Updated

Impact Manipulation of product reviews via API

Patches We recommend updating to the current version 6.4.3.1. You can get the update to 6.4.3.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

Other sources

Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a vulnerability that allows manipulation of product reviews via API. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

— MITRE

Affected Software

5 affected componentsFixes available
Shopware Shopware>=6.1.0<6.4.3.1
composer/shopware/core<=6.4.3.0
composer/shopware/platform<=6.4.3.0
composer/shopware/core<=6.4.3.0
6.4.3.1
composer/shopware/platform<=6.4.3.0
6.4.3.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/shopware/core to a version that resolves this vulnerability.

    Fixed in 6.4.3.1
  2. Upgrade

    Upgrade composer/shopware/platform to a version that resolves this vulnerability.

    Fixed in 6.4.3.1
  3. Upgrade

    Upgrade Shopware to a version that resolves this vulnerability.

    Fixed in 6.4.3.1

Event History

Aug 16, 2021
CVE Published
via MITRE·06:55 PM
Data Sourced
via MITRE·06:55 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·07:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Aug 30, 2021
Advisory Published
via GitHub·04:14 PM
Data Sourced
via GitHub·04:14 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·04:14 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2021-37707?

CVE-2021-37707 is a vulnerability in Shopware, an open source eCommerce platform, that allows manipulation of product reviews via API.

2

How severe is CVE-2021-37707?

CVE-2021-37707 has a severity rating of 7.5 (High).

3

Which versions of Shopware are affected by CVE-2021-37707?

Versions prior to 6.4.3.1 of Shopware are affected by CVE-2021-37707.

4

How can I fix CVE-2021-37707?

Update your Shopware version to 6.4.3.1 or apply corresponding security measures for older versions (6.1, 6.2, and 6.3) via a plugin.

5

Where can I find more information about CVE-2021-37707?

You can find more information about CVE-2021-37707 at the following references: [Reference 1](https://github.com/shopware/platform/commit/912b96de3b839c6c5525c98cbb58f537c2d838be) and [Reference 2](https://github.com/shopware/platform/security/advisories/GHSA-9f8f-574q-8jmf)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203