CVE-2021-37710: Cross-Site Scripting via SVG media files

Published Aug 16, 2021
·
Updated

Impact Cross-Site Scripting via SVG media files

Patches We recommend updating to the current version 6.4.3.1. You can get the update to 6.4.3.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Other sources

Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a Cross-Site Scripting vulnerability via SVG media files. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

— MITRE

Affected Software

5 affected componentsFixes available
Shopware Shopware<6.4.3.1
composer/shopware/core<=6.4.3.0
composer/shopware/platform<=6.4.3.0
composer/shopware/platform<=6.4.3.0
6.4.3.1
composer/shopware/core<=6.4.3.0
6.4.3.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/shopware/platform to a version that resolves this vulnerability.

    Fixed in 6.4.3.1
  2. Upgrade

    Upgrade composer/shopware/core to a version that resolves this vulnerability.

    Fixed in 6.4.3.1
  3. Upgrade

    Upgrade Shopware to a version that resolves this vulnerability.

    Fixed in 6.4.3.1
  4. Compensating control

    For older Shopware versions 6.1, 6.2, and 6.3, install the corresponding security-measures plugin to mitigate Cross-Site Scripting via SVG media files.

Event History

Aug 16, 2021
CVE Published
via MITRE·10:20 PM
Data Sourced
via MITRE·10:20 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·11:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Aug 23, 2021
Advisory Published
via GitHub·07:43 PM
Data Sourced
via GitHub·07:43 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·07:43 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2021-37710?

CVE-2021-37710 is a Cross-Site Scripting vulnerability in Shopware eCommerce platform versions prior to 6.4.3.1.

2

How severe is CVE-2021-37710?

CVE-2021-37710 has a severity score of 5.4, which is considered high.

3

How does CVE-2021-37710 affect Shopware?

CVE-2021-37710 affects Shopware versions prior to 6.4.3.1, allowing for Cross-Site Scripting attacks via SVG media files.

4

How can I fix CVE-2021-37710?

To fix CVE-2021-37710, it is recommended to update to Shopware version 6.4.3.1, which contains a patch for the vulnerability.

5

Are there any workarounds for older versions of Shopware?

Yes, for older versions (6.1, 6.2, and 6.3), corresponding security measures are available through a plugin.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203