CVE-2021-38003: Inappropriate implementation in V8

Published Oct 26, 2021
·
Updated

Google Chromium V8 Engine has a bug in JSON.stringify, where the internal TheHole value can leak to script code, causing memory corruption. This vulnerability could affect multiple web browsers that utilize Chromium, including, but not limited to, Google Chrome, Microsoft Edge, and Opera.

Other sources

Inappropriate implementation in V8 in Google Chrome prior to 95.0.4638.69 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Credit

Clément Lecigne(Google TAG), Samuel Groß(Google Project Zero)

Affected Software

17 affected componentsFixes available
Google Chrome<95.0.4638.69
Fedoraproject Fedora=34
Debian Debian Linux=10.0
Debian Debian Linux=11.0
Google Chromium V8
Google Chrome<95.0.4638.69
95.0.4638.69
alpine/qt5-qtwebengine<5.15.3_git20211112-r1
5.15.3_git20211112-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
alpine/qt5-qtwebengine<5.15.3_git20211127-r0
5.15.3_git20211127-r0
debian/chromium
150.0.7871.100-1~deb12u1156.0.8078.79-1~deb12u1150.0.7871.181-1~deb13u1156.0.8078.79-1~deb13u1156.0.8078.79-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 95.0.4638.69
  2. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211112-r1
  3. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211127-r0
  4. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1

Event History

Oct 26, 2021
CVE Published
12:00 AM
Data Sourced
12:00 AM
SeverityWeaknessAffected Software
Nov 3, 2021
Data Sourced
via CISA·12:00 AM
DescriptionWeaknessAffected Software
Nov 23, 2021
CVE Published
via MITRE·09:30 PM
Data Sourced
via MITRE·09:30 PM
DescriptionWeakness
Data Sourced
via NVD·10:15 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·10:15 PM
DescriptionSeverityAffected Software
Jan 7, 2023
Exploit Published
via GitHub·06:09 AM

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID for this vulnerability?

The vulnerability ID for this vulnerability is CVE-2021-38003.

2

What is the title of this vulnerability?

The title of this vulnerability is Google Chromium V8 Memory Corruption Vulnerability.

3

What software is affected by this vulnerability?

Web browsers that utilize Chromium, including Google Chrome and Microsoft Edge, are affected by this vulnerability.

4

What is the severity of CVE-2021-38003?

CVE-2021-38003 has a severity rating of 8.8 (high).

5

How does CVE-2021-38003 affect Google Chrome?

Google Chrome versions up to 95.0.4638.69 are affected by CVE-2021-38003.

6

How does CVE-2021-38003 affect Fedora?

Fedora version 34 is affected by CVE-2021-38003.

7

How does CVE-2021-38003 affect Debian Linux 10?

Debian Linux version 10.0 is affected by CVE-2021-38003.

8

How does CVE-2021-38003 affect Debian Linux 11?

Debian Linux version 11.0 is affected by CVE-2021-38003.

9

How do I fix CVE-2021-38003 on Google Chrome?

To fix CVE-2021-38003 on Google Chrome, update to versions 95.0.4638.69 or newer.

10

How do I fix CVE-2021-38003 on Fedora?

To fix CVE-2021-38003 on Fedora, apply the necessary updates mentioned in the reference link.

11

How do I fix CVE-2021-38003 on Debian Linux 10?

To fix CVE-2021-38003 on Debian Linux 10, update the chromium package to version 90.0.4430.212-1~deb10u1 or newer.

12

How do I fix CVE-2021-38003 on Debian Linux 11?

To fix CVE-2021-38003 on Debian Linux 11, update the chromium package to version 116.0.5845.180-1~deb11u1 or newer.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203