CVE-2021-38204: Use After Free

Published Aug 8, 2021
·
Updated

drivers/usb/host/max3421-hcd.c in the Linux kernel before 5.13.6 allows physically proximate attackers to cause a denial of service (use-after-free and panic) by removing a MAX-3421 USB device in certain situations.

Other sources

In max3421setaddress and related functions of max3421-hcd.c, there is a possible way to corrupt memory due to a use after free. This could lead to local escalation of privilege with physical/USB access to the device, with no additional execution privileges needed. User interaction is not needed for exploitation.

— OSV

Affected Software

5 affected componentsFixes available
Linux Linux kernel<5.13.6
Debian Debian Linux=9.0
debian/linux
5.10.223-15.10.234-16.1.129-16.1.135-16.12.25-16.12.27-1
Google Android
android/:linux_kernel:>=:0<:2021-12-05
:2021-12-05

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
  2. Upgrade

    Upgrade android/:linux_kernel: to a version that resolves this vulnerability.

    Fixed in :2021-12-05
  3. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Fixed in 5.13.6

Event History

Aug 8, 2021
CVE Published
via MITRE·07:25 PM
Data Sourced
via MITRE·07:25 PM
Description
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Dec 1, 2021
Advisory Published
via OSV·12:00 AM
Data Sourced
via OSV·12:00 AM
DescriptionAffected Software
Dec 6, 2021
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2021-38204?

CVE-2021-38204 has a severity rating that indicates it can lead to a denial of service due to a use-after-free vulnerability.

2

How do I fix CVE-2021-38204?

To fix CVE-2021-38204, update the Linux kernel to version 5.13.6 or later.

3

Which Linux kernel versions are affected by CVE-2021-38204?

CVE-2021-38204 affects the Linux kernel versions prior to 5.13.6.

4

Can CVE-2021-38204 be exploited remotely?

CVE-2021-38204 requires physical proximity to exploit, indicating it cannot be exploited remotely.

5

What type of impact does CVE-2021-38204 have on systems?

CVE-2021-38204 can cause a denial of service by creating a panic when a MAX-3421 USB device is removed.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203