CVE-2021-3838: Deserialization of Untrusted Data in dompdf/dompdf
[Unknown description]
Other sources
Deserialization of Untrusted Data in dompdf/dompdf
— Packagist
Deserialization of Untrusted Data using PHAR deserialization
— Debian
DomPDF before version 2.0.0 is vulnerable to PHAR (PHP Archive) deserialization due to a lack of checking on the protocol before passing it into the filegetcontents() function. An attacker who can upload files of any type to the server can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution, especially when DOMPdf is used with frameworks with documented POP chains like Laravel or vulnerable developer code.
— GitHub
DomPDF before version 2.0.0 is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the filegetcontents() function. An attacker who can upload files of any type to the server can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution, especially when DOMPdf is used with frameworks with documented POP chains like Laravel or vulnerable developer code.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/php-dompdfto a version that resolves this vulnerability.Fixed in 2.0.2+dfsg-1Fixed in 2.0.0 - Upgrade
Upgrade
ubuntu/php-dompdfto a version that resolves this vulnerability.Fixed in 0.6.1+dfsg-2ubuntu1+ - Upgrade
Upgrade
ubuntu/php-dompdfto a version that resolves this vulnerability.Fixed in 0.6.2+dfsg-3ubuntu0.18.04.1~ - Upgrade
Upgrade
ubuntu/php-dompdfto a version that resolves this vulnerability.Fixed in 0.6.2+dfsg-3ubuntu0.20.04.1 - Upgrade
Upgrade
ubuntu/php-dompdfto a version that resolves this vulnerability.Fixed in 0.6.2+dfsg-3.1ubuntu0.1 - Upgrade
Upgrade
debian/php-dompdfto a version that resolves this vulnerability.Fixed in 0.6.2+dfsg-3+deb10u2Fixed in 2.0.3+dfsg-1Fixed in 2.0.4+dfsg-1 - Upgrade
Upgrade
composer/dompdf/dompdfto a version that resolves this vulnerability.Fixed in 2.0.0 - Upgrade
Upgrade
dompdf/dompdfto a version that resolves this vulnerability.Fixed in 2.0.0
Event History
Frequently Asked Questions
What is CVE-2021-3838?
CVE-2021-3838 is a vulnerability related to the deserialization of untrusted data using PHAR deserialization.
How does CVE-2021-3838 affect software?
CVE-2021-3838 affects the php-dompdf package in various versions of Debian and Ubuntu.
What is the severity of CVE-2021-3838?
The severity of CVE-2021-3838 is yet to be determined, but it is recommended to apply the available remedies to mitigate the vulnerability.
How can I fix CVE-2021-3838?
To fix CVE-2021-3838, it is recommended to update the php-dompdf package to the specified versions or apply the relevant security patches provided by the distribution.
Where can I find more information about CVE-2021-3838?
You can find more information about CVE-2021-3838 on the GitHub page of dompdf and the related reference links.