CVE-2021-39134: UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

Published Aug 31, 2021
·
Updated

@npmcli/arborist, the library that calculates dependency trees and manages the nodemodules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is, in part, accomplished by resolving dependency specifiers defined in package.json manifests for dependencies with a specific name, and nesting folders to resolve conflicting dependencies. When multiple dependencies differ only in the case of their name, Arborist's internal data structure saw them as separate items that could coexist within the same level in the nodemodules hierarchy. However, on case-insensitive file systems (such as macOS and Windows), this is not the case. Combined with a symlink dependency such as file:/some/path, this allowed an attacker to create a situation in which arbitrary contents could be written to any location on the filesystem. For example, a package pwn-a could define a dependency in their package.json file such as "foo": "file:/some/path". Another package, pwn-b could define a dependency such as FOO: "file:foo.tgz". On case-insensitive file systems, if pwn-a was installed, and then pwn-b was installed afterwards, the contents of foo.tgz would be written to /some/path, and any existing contents of /some/path would be removed. Anyone using npm v7.20.6 or earlier on a case-insensitive filesystem is potentially affected. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above.

Other sources

npm 6 update - node-tar, aborist, npm client modules. These are vulnerabilities in the node-tar, arborist, and npm cli modules which are related to the initial reports and subsequent remediation of node-tar vulnerabilities CVE-2021-32803 and CVE-2021-32804. Subsequent internal security review of node-tar and additional external bounty reports have resulted in another 5 CVE being remediated in core npm CLI dependencies including node-tar, and npm arborist. You can read more about it in: https://github.com/npm/node-tar/security/advisories/GHSA-9r2w-394v-53qc, https://github.com/npm/node-tar/security/advisories/GHSA-qq89-hq3f-393p, https://github.com/npm/node-tar/security/advisories/GHSA-5955-9wpr-37jh, https://github.com/npm/arborist/security/advisories/GHSA-2h3h-q99f-3fhc), https://github.com/npm/arborist/security/advisories/GHSA-gmw6-94gg-2rc2

— Node.Js

Affected Software

10 affected componentsFixes available
npmjs Arborist Node.js<2.8.2
npmjs npm<7.20.7
Oracle GraalVM=20.3.3
Oracle GraalVM=21.2.0
Siemens Sinec Infrastructure Network Services<1.0.1.1
All of the following
npmjs Arborist Node.js<2.8.2
npmjs npm<7.20.7
Node.js Node.js>=12.0.0<12.22.6, >=14.0.0<14.17.6
12.22.614.17.6
Node.js Node.js>=12.0.0<12.22.6
12.22.6
Node.js Node.js>=14.0.0<14.17.6
14.17.6

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.22.6Fixed in 14.17.6
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 12.22.6
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 14.17.6
  4. Upgrade

    Upgrade npm to a version that resolves this vulnerability.

    Fixed in 7.20.7

Event History

Aug 31, 2021
CVE Published
via Node.js·03:03 PM
Data Sourced
via Node.js·03:03 PM
SeverityAffected Software
CVE Published
via MITRE·04:55 PM
Data Sourced
via MITRE·04:55 PM
DescriptionSeverityWeakness
Data Sourced
via NVD·05:15 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the vulnerability ID for this vulnerability?

The vulnerability ID for this vulnerability is CVE-2021-39134.

2

What is the severity of CVE-2021-39134?

The severity of CVE-2021-39134 is high (7.8).

3

What software is affected by CVE-2021-39134?

The software affected by CVE-2021-39134 includes Npmjs Arborist (up to version 2.8.2), Oracle GraalVM (version 20.3.3 and 21.2.0), and Siemens Sinec Infrastructure Network Services (up to version 1.0.1.1).

4

What is the description of CVE-2021-39134?

CVE-2021-39134 is a vulnerability in `@npmcli/arborist`, a library used by npm to manage package dependency trees and the `node_modules` folder hierarchy.

5

How can I fix CVE-2021-39134?

To fix CVE-2021-39134, you should update Npmjs Arborist to a version higher than 2.8.2 and Siemens Sinec Infrastructure Network Services to a version higher than 1.0.1.1.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203