CVE-2021-41864: Integer Overflow
An out-of-bounds (OOB) memory write flaw was found in preallocelemsandfreelist in kernel/bpf/stackmap.c in the bpf iin the Linux kernel. In this flaw, the multiplication to calculate the size could lead to an integer overflow, and this could allow a local attacker, with a special user privilege to gain access to out-of-bounds memory leading to a system crash or a leak of internal kernel information.
Reference and upstream patch: https://github.com/torvalds/linux/commit/30e29a9a2bc6a4888335a6ede968b75cd329657a
Other sources
An out-of-bounds (OOB) memory write flaw was found in preallocelemsandfreelist in kernel/bpf/stackmap.c in the bpf in the Linux kernel. In this flaw, the multiplication to calculate the size could lead to an integer overflow which could allow a local attacker, with a special user privilege, to gain access to out-of-bounds memory leading to a system crash or a leak of internal kernel information.
In preallocelemsandfreelist of stackmap.c, there is a possible out of bounds write due to an integer overflow. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.
— OSV
preallocelemsandfreelist in kernel/bpf/stackmap.c in the Linux kernel before 5.14.12 allows unprivileged users to trigger an eBPF multiplication integer overflow with a resultant out-of-bounds write.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernel-rtto a version that resolves this vulnerability.Fixed in 0:4.18.0-372.9.1.rt7.166.el8 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-372.9.1.el8 - Upgrade
Upgrade
android/:linux_kernel:to a version that resolves this vulnerability.Fixed in :2022-03-05 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.15-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 5.14.12
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2021-41864?
CVE-2021-41864 has a high severity rating due to its potential for exploitation leading to significant impacts on affected systems.
How do I fix CVE-2021-41864?
To fix CVE-2021-41864, update to the patched versions of the affected packages, specifically kernel-rt and kernel packages under Red Hat, or update your Linux kernel to versions beyond 5.14.12.
Who is affected by CVE-2021-41864?
CVE-2021-41864 affects various distributions of the Linux kernel and specific versions of the NetApp cloud backup solutions.
What types of attacks can exploit CVE-2021-41864?
CVE-2021-41864 can be exploited by local attackers with special privileges to perform out-of-bounds memory writes, potentially leading to escalation of privileges.
Is CVE-2021-41864 a kernel vulnerability?
Yes, CVE-2021-41864 is a vulnerability within the Linux kernel, specifically in the BPF subsystem.