CVE-2021-4204: Input Validation
An out of bounds (OOB) memory access flaw was found in the Linux kernel's eBPF due to an Improper Input Validation. This could allow a local attacker with a special privilege to crash the system or leak kernel internal information.
Reference: https://www.openwall.com/lists/oss-security/2022/01/11/4
Other sources
An out-of-bounds (OOB) memory access flaw was found in the Linux kernel's eBPF due to an Improper Input Validation. This flaw allows a local attacker with a special privilege to crash the system or leak internal information.
— Launchpad
Linux Kernel could allow a local authenticated attacker to gain elevated privileges on the system, caused by improper input validation in the handling of eBPF programs. By executing a specially-crafted eBPF program, an authenticated attacker could exploit this vulnerability to gain elevated privileges and execute code in the context of the kernel.
— IBM
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.17.3-1 - Configuration
Disable unprivileged eBPF by running: sudo sysctl kernel.unprivileged_bpf_disabled=1
Linux kernel eBPF kernel.unprivileged_bpf_disabled = 1
Event History
Frequently Asked Questions
What is the severity of CVE-2021-4204?
CVE-2021-4204 has been classified as a medium severity vulnerability due to its potential to crash systems or leak kernel information.
How do I fix CVE-2021-4204?
To fix CVE-2021-4204, update your Linux kernel to version 5.10.223-1 or later.
What are the affected versions for CVE-2021-4204?
CVE-2021-4204 affects Linux Kernel versions up to 5.8.0, and also specific versions of Debian Debian Linux and Red Hat Enterprise Linux.
Who can exploit CVE-2021-4204?
CVE-2021-4204 can be exploited by a local attacker with special privileges on the affected system.
What type of vulnerability is CVE-2021-4204?
CVE-2021-4204 is an out of bounds memory access vulnerability caused by improper input validation in the Linux kernel's eBPF.