CVE-2021-42782: Buffer Overflow
Last updated 10 April 2025
Other sources
Stack buffer overflow issues were found in Opensc before version 0.22.0 in various places that could potentially crash programs using the library.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/openscto a version that resolves this vulnerability.Fixed in 0.22.0 - Upgrade
Upgrade
debian/openscto a version that resolves this vulnerability.Fixed in 0.21.0-1+deb11u1Fixed in 0.23.0-0.3+deb12u2Fixed in 0.26.1-1 - Upgrade
Upgrade
OpenSCto a version that resolves this vulnerability.Fixed in 0.22.0
Event History
Frequently Asked Questions
What is CVE-2021-42782?
CVE-2021-42782 is a vulnerability found in Opensc before version 0.22.0 that can cause stack buffer overflow issues.
How severe is CVE-2021-42782?
The severity of CVE-2021-42782 is 5.3, which is considered medium.
Which software versions are affected by CVE-2021-42782?
Opensc versions before 0.22.0, Fedora version 33, and Red Hat Opensc package version before 0.22.0 are affected by CVE-2021-42782.
How can CVE-2021-42782 potentially impact programs using Opensc?
CVE-2021-42782 can potentially crash programs using the Opensc library due to stack buffer overflow issues.
Where can I find more information about CVE-2021-42782?
You can find more information about CVE-2021-42782 on the Red Hat Bugzilla and the corresponding GitHub commits.