CVE-2021-45095: Infoleak
Last updated 25 April 2025
Other sources
pepsockaccept in net/phonet/pep.c in the Linux kernel through 5.15.8 has a refcount leak.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1
Event History
Frequently Asked Questions
What is the severity of CVE-2021-45095?
CVE-2021-45095 has a moderate severity rating due to its refcount leak in the Linux kernel.
How do I fix CVE-2021-45095?
To fix CVE-2021-45095, upgrade to a Linux kernel version greater than 5.15.8 or apply the relevant patches provided in the Debian package updates.
Which Linux kernel versions are affected by CVE-2021-45095?
CVE-2021-45095 affects Linux kernel versions up to and including 5.15.8.
Is CVE-2021-45095 present in Debian versions?
Yes, CVE-2021-45095 is present in Debian Linux versions 9.0, 10.0, and 11.0.
What are the packages affected by CVE-2021-45095 in Debian?
The affected package for CVE-2021-45095 in Debian is the 'linux' package, specifically versions prior to the fixed versions listed in Debian's updates.