CVE-2021-45480: Medium severity Linux Linux kernel vulnerability
An issue was discovered in the Linux kernel before 5.15.11. There is a memory leak in the rdsconncreate() function in net/rds/connection.c in a certain combination of circumstances.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 5.15.11
Event History
Frequently Asked Questions
What is the severity of CVE-2021-45480?
CVE-2021-45480 has a moderate severity due to the potential for a memory leak in the Linux kernel.
How do I fix CVE-2021-45480?
To fix CVE-2021-45480, update your Linux kernel to version 5.15.11 or higher.
Which Linux kernel versions are affected by CVE-2021-45480?
CVE-2021-45480 affects Linux kernel versions prior to 5.15.11.
What is the impact of CVE-2021-45480?
The impact of CVE-2021-45480 is a memory leak that can lead to performance degradation over time.
Is CVE-2021-45480 specific to certain distributions?
Yes, CVE-2021-45480 affects various distributions that use vulnerable versions of the Linux kernel, including Debian.