CVE-2021-47086: phonet/pep: refuse to enable an unbound pipe

Published Mar 4, 2024
·
Updated

In the Linux kernel, the following vulnerability has been resolved:

phonet/pep: refuse to enable an unbound pipe

This ioctl() implicitly assumed that the socket was already bound to a valid local socket name, i.e. Phonet object. If the socket was not bound, two separate problems would occur:

1) We'd send an pipe enablement request with an invalid source object. 2) Later socket calls could BUG on the socket unexpectedly being connected yet not bound to a valid object.

Affected Software

14 affected componentsFixes available
Linux Linux kernel<4.4.297
Linux Linux kernel>=4.5<4.9.295
Linux Linux kernel>=4.10<4.14.260
Linux Linux kernel>=4.15<4.19.223
Linux Linux kernel>=4.20<5.4.169
Linux Linux kernel>=5.5<5.10.89
Linux Linux kernel>=5.11<5.15.12
Linux Linux kernel=5.16-rc1
Linux Linux kernel=5.16-rc2
Linux Linux kernel=5.16-rc3
Linux Linux kernel=5.16-rc4
Linux Linux kernel=5.16-rc5
Linux Linux kernel=5.16-rc6
debian/linux
5.10.223-15.10.234-16.1.129-16.1.135-16.12.22-16.12.25-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.22-1Fixed in 6.12.25-1

Event History

Mar 4, 2024
CVE Published
via MITRE·06:06 PM
Data Sourced
via MITRE·06:06 PM
Description

Frequently Asked Questions

1

What is the severity of CVE-2021-47086?

CVE-2021-47086 is considered a medium severity vulnerability in the Linux kernel.

2

How do I fix CVE-2021-47086?

To fix CVE-2021-47086, update your Linux kernel to versions 5.10.223-1, 5.10.226-1, 6.1.123-1, 6.1.119-1, 6.12.10-1, or 6.12.11-1.

3

Which versions of the Linux kernel are affected by CVE-2021-47086?

CVE-2021-47086 affects several versions of the Linux kernel, specifically versions prior to 4.4.297 and between 4.5 and 5.15.12.

4

What components are involved in CVE-2021-47086?

CVE-2021-47086 involves the phonet/pep component of the Linux kernel.

5

Is CVE-2021-47086 a remote code execution vulnerability?

No, CVE-2021-47086 does not directly lead to remote code execution; it primarily concerns socket binding issues.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203