CVE-2022-0333: Insufficient user authorization in Moodle

Published Jan 21, 2022
·
Updated

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.

Other sources

Insufficient user authorization in Moodle

— Packagist

Affected Software

12 affected componentsFixes available
composer/moodle/moodle>=3.9<3.9.11
3.9.11
composer/moodle/moodle>=3.10<3.10.8
3.10.8
composer/moodle/moodle>=3.11<3.11.5
3.11.5
redhat/moodle<3.11.5
3.11.5
redhat/moodle 3.10.9 and moodle<3.9.12
3.9.12
Moodle Moodle<=3.8.9
Moodle Moodle>=3.9.0<3.9.12
Moodle Moodle>=3.10.0<3.10.9
Moodle Moodle>=3.11.0<3.11.5
composer/moodle/moodle>=3.9, <3.9.11
3.9.11
composer/moodle/moodle>=3.10, <3.10.8
3.10.8
composer/moodle/moodle>=3.11, <3.11.5
3.11.5

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.9.11
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.10.8
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 3.11.5
  4. Upgrade

    Upgrade redhat/moodle to a version that resolves this vulnerability.

    Fixed in 3.11.5
  5. Upgrade

    Upgrade redhat/moodle 3.10.9 and moodle to a version that resolves this vulnerability.

    Fixed in 3.9.12
  6. Configuration

    Restrict the calendar:manageentries capability so managers cannot access or modify user-level calendar events.

    Moodle calendar calendar:manageentries capability = restricted from user-level events

Event History

Jan 25, 2022
CVE Published
via MITRE·07:11 PM
Data Sourced
via MITRE·07:11 PM
DescriptionWeakness
Data Sourced
via NVD·08:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Jan 28, 2022
Advisory Published
10:08 PM
Data Sourced
via GitHub·10:08 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·10:08 PM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is CVE-2022-0333?

CVE-2022-0333 is a vulnerability found in Moodle that allows managers to access or modify any calendar event, but should have been restricted from accessing user level events.

2

What versions of Moodle are affected by CVE-2022-0333?

Moodle versions 3.11 to 3.11.4, 3.10 to 3.10.8, and 3.9 to 3.9.11 are affected by CVE-2022-0333.

3

What is the severity of CVE-2022-0333?

CVE-2022-0333 has a severity rating of 3.8, which is considered medium.

4

How can I fix CVE-2022-0333?

To fix CVE-2022-0333, you should update Moodle to versions 3.9.11, 3.10.8, or 3.11.5, depending on the version you are running.

5

Where can I find more information about CVE-2022-0333 vulnerability in Moodle?

You can find more information about CVE-2022-0333 in Moodle on the following references: [1] [2] [3].

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203