CVE-2022-0516: Infoleak
A vulnerability was found in kvms390guestsidaop in arch/s390/kvm/kvm-s390.c in KVM for s390 in the Linux kernel. In this flaw, a local attacker with a normal user privilege may impact in unauthorized memory write access.
Other sources
A vulnerability was found in kvms390guestsidaop in the arch/s390/kvm/kvm-s390.c function in KVM for s390 in the Linux kernel. This flaw allows a local attacker with a normal user privilege to obtain unauthorized memory write access.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-348.20.1.el8_5 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 0:4.18.0-305.40.1.el8_4 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 5.10.223-1Fixed in 5.10.234-1Fixed in 6.1.129-1Fixed in 6.1.135-1Fixed in 6.12.25-1Fixed in 6.12.27-1 - Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 5.17 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 5.17-rc4 - Configuration
Add `install kvm /bin/true` to `/etc/modprobe.d/disable-kvm.conf` to prevent the kvm.ko module from loading.
kvm.ko install kvm = /bin/true
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2022-0516?
CVE-2022-0516 is classified as a medium severity vulnerability due to its potential for unauthorized memory writes.
What software is affected by CVE-2022-0516?
CVE-2022-0516 affects specific versions of the Linux kernel including 4.18.0-348.20.1.el8_5 and others up to version 5.17.
How do I fix CVE-2022-0516?
To fix CVE-2022-0516, you should update to the patched versions of the kernel provided by your distribution, such as Red Hat or Debian.
Who can exploit CVE-2022-0516?
CVE-2022-0516 can be exploited by a local attacker with normal user privileges.
What are the consequences of CVE-2022-0516 exploitation?
Exploitation of CVE-2022-0516 may allow an attacker to perform unauthorized memory write access, potentially leading to data corruption or further privilege escalation.