CVE-2022-0581: Use After Free
Crash in the CMS protocol dissector in Wireshark 3.6.0 to 3.6.1 and 3.4.0 to 3.4.11 allows denial of service via packet injection or crafted capture file
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 4.0.17-0+deb12u3Fixed in 4.4.18-0+deb13u1Fixed in 4.4.19-0+deb13u1Fixed in 4.6.9-1 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 3.4.13-r0 - Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 3.6.2-1
Event History
Frequently Asked Questions
What is CVE-2022-0581?
CVE-2022-0581 is a vulnerability in Wireshark versions 3.6.0 to 3.6.1 and 3.4.0 to 3.4.11 that allows denial of service through packet injection or crafted capture file.
How does CVE-2022-0581 impact Wireshark?
CVE-2022-0581 can lead to a crash in the CMS protocol dissector in Wireshark, resulting in denial of service.
What is the severity of CVE-2022-0581?
CVE-2022-0581 has a severity rating of 7.5 (high).
Which software versions are affected by CVE-2022-0581?
Wireshark versions 3.6.0 to 3.6.1 and 3.4.0 to 3.4.11 are affected by CVE-2022-0581.
How can CVE-2022-0581 be fixed?
Update to Wireshark version 3.4.12 or higher, or 3.6.2 or higher, to fix CVE-2022-0581.