CVE-2022-1049: High severity ClusterLabs pcs vulnerability
A flaw was found in the Pacemaker configuration tool (pcs). The pcs daemon was allowing expired accounts, and accounts with expired passwords to login when using PAM authentication. Therefore, unprivileged expired accounts that have been denied access could still login.
Other sources
Pacemakers daemon pcsd allows authentication via PAMs pamauthenticate. Unfortunately the authorization via pamacctmgmt has been omitted. Therefore unprivileged expired accounts that have been denied access can still login.
References: https://huntr.dev/bounties/7aa921fc-a568-4fd8-96f4-7cd826246aa5/ https://github.com/ClusterLabs/pcs/commit/fb860005117dc9e092649687dfa1304fb423efc5
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/pcsto a version that resolves this vulnerability.Fixed in 0.11.5-1+deb12u1Fixed in 0.12.0.2-1Fixed in 0.12.3.1-2 - Upgrade
Upgrade
debian/pcsto a version that resolves this vulnerability.Fixed in 0.11.3-1
Event History
Frequently Asked Questions
What is CVE-2022-1049?
CVE-2022-1049 is a vulnerability found in the Pacemaker configuration tool (pcs) that allows expired and expired password accounts to login using PAM authentication.
What is the severity of CVE-2022-1049?
The severity of CVE-2022-1049 is high, with a severity value of 8.8.
How does CVE-2022-1049 affect the software?
CVE-2022-1049 affects systems running pcs version 0.10.1-2 up to and including 0.11.2, as well as ClusterLabs pcs and Debian Debian Linux versions 10.0 and 11.0.
How can I fix CVE-2022-1049?
To fix CVE-2022-1049, upgrade the pcs package to version 0.10.1-2+deb10u1, 0.10.8-1+deb11u1, 0.11.5-1, or 0.11.6-1, depending on your system.
Where can I find more information about CVE-2022-1049?
You can find more information about CVE-2022-1049 at the following references: [link1], [link2], [link3].