CVE-2022-1328: Buffer Overflow
Buffer Overflow in uudecoder in Mutt affecting all versions starting from 0.94.13 before 2.2.3 allows read past end of input line
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/muttto a version that resolves this vulnerability.Fixed in 2.2.12-0.1~deb12u1Fixed in 2.2.9-1+deb12u1Fixed in 2.2.13-1+deb13u1Fixed in 2.2.13-1+deb13u2Fixed in 2.4.1-1.1 - Upgrade
Upgrade
debian/neomuttto a version that resolves this vulnerability.Fixed in 20220429+dfsg1-4.1Fixed in 20250510+dfsg-2Fixed in 20260616+dfsg-1 - Upgrade
Upgrade
alpine/muttto a version that resolves this vulnerability.Fixed in 2.2.3-r0 - Upgrade
Upgrade
debian/muttto a version that resolves this vulnerability.Fixed in 2.2.3-1 - Upgrade
Upgrade
debian/neomuttto a version that resolves this vulnerability.Fixed in 20220429+dfsg1-1 - Upgrade
Upgrade
redhat/muttto a version that resolves this vulnerability.Fixed in 2.2.3 - Upgrade
Upgrade
muttto a version that resolves this vulnerability.Fixed in 2.2.3
Event History
Frequently Asked Questions
What is CVE-2022-1328?
CVE-2022-1328 is a buffer overflow vulnerability in the uudecoder component of Mutt, affecting all versions starting from 0.94.13 before 2.2.3.
How does CVE-2022-1328 impact Mutt?
CVE-2022-1328 allows an attacker to read past the end of an input line, potentially leading to unauthorized access or remote code execution.
Which software versions are affected by CVE-2022-1328?
All versions of Mutt starting from 0.94.13 before 2.2.3 are affected.
What is the severity of CVE-2022-1328?
CVE-2022-1328 has a severity rating of 5.3 (medium).
How can I fix CVE-2022-1328 in Mutt?
To fix CVE-2022-1328, it is recommended to upgrade Mutt to version 2.2.3 or later, which includes a patch for the vulnerability.