CVE-2022-1657: JupiterX Theme <= 2.0.6 and Jupiter Theme <= 6.10.1 - Authenticated Path Traversal and Local File Inclusion
Vulnerable versions of the Jupiter (<= 6.10.1) and JupiterX (<= 2.0.6) Themes allow logged-in users, including subscriber-level users, to perform Path Traversal and Local File inclusion. In the JupiterX theme, the jupiterxcploadpaneaction AJAX action present in the lib/admin/control-panel/control-panel.php file calls the loadcontrolpanelpane function. It is possible to use this action to include any local PHP file via the slug parameter. The Jupiter theme has a nearly identical vulnerability which can be exploited via the mkacploadpaneaction AJAX action present in the framework/admin/control-panel/logic/functions.php file, which calls the mkacploadpaneaction function.
Affected Software
Event History
Frequently Asked Questions
What is the severity of CVE-2022-1657?
CVE-2022-1657 is a critical vulnerability affecting Jupiter and JupiterX themes, enabling unauthorized access and file manipulation.
How do I fix CVE-2022-1657?
To mitigate CVE-2022-1657, update the Jupiter theme to version 6.10.2 or later and the JupiterX theme to version 2.0.7 or later.
What types of attacks can CVE-2022-1657 enable?
CVE-2022-1657 can enable path traversal and local file inclusion attacks, allowing attackers to access sensitive files on the server.
Who is affected by CVE-2022-1657?
Logged-in users, including those with subscriber-level permissions, are affected by CVE-2022-1657 in vulnerable versions of the Jupiter and JupiterX themes.
What versions of the Jupiter theme are vulnerable to CVE-2022-1657?
Jupiter versions up to and including 6.10.1 are vulnerable to CVE-2022-1657.