CVE-2022-21265: Low severity Oracle MySQL vulnerability
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are 8.0.27 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server.
External References:
https://www.oracle.com/security-alerts/cpujan2022.html#AppendixMSQL
Other sources
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Optimizer). Supported versions that are affected are 8.0.27 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. CVSS 3.1 Base Score 3.8 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L).
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/mysqlto a version that resolves this vulnerability.Fixed in 8.0.28
Event History
Frequently Asked Questions
What is the vulnerability ID for this MySQL Server vulnerability?
The vulnerability ID for this MySQL Server vulnerability is CVE-2022-21265.
What is the severity rating of CVE-2022-21265?
The severity rating of CVE-2022-21265 is medium with a value of 3.8.
Which versions of MySQL Server are affected?
The affected versions of MySQL Server are 8.0.27 and prior.
What is the impact of this vulnerability?
This vulnerability allows a high privileged attacker with network access to compromise MySQL Server.
How can I fix this vulnerability?
To fix this vulnerability, update MySQL Server to version 8.0.28 or higher.