CVE-2022-21663: Authenticated Object Injection in Multisites in WordPress

Published Jan 6, 2022
·
Updated

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.

Affected Software

10 affected componentsFixes available
WordPress WordPress<5.8.3
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Debian Debian Linux=11.0
Fedoraproject Fedora=34
Fedoraproject Fedora=35
debian/wordpress<5.8.3+dfsg1-1
5.8.3+dfsg1-1
debian/wordpress<5.8.3+dfsg1-1
5.8.3+dfsg1-1
debian/wordpress<5.8.3+dfsg1-1
5.8.3+dfsg1-1
debian/wordpress
6.1.9+dfsg1-0+deb12u16.8.7+dfsg1-0+deb13u16.8.12+dfsg1-0+deb13u17.1.4+dfsg1-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/wordpress to a version that resolves this vulnerability.

    Fixed in 6.1.9+dfsg1-0+deb12u1Fixed in 6.8.7+dfsg1-0+deb13u1Fixed in 6.8.12+dfsg1-0+deb13u1Fixed in 7.1.4+dfsg1-1
  2. Upgrade

    Upgrade debian/wordpress to a version that resolves this vulnerability.

    Fixed in 5.8.3+dfsg1-1
  3. Upgrade

    Upgrade WordPress to a version that resolves this vulnerability.

    Fixed in 5.8.3
  4. Configuration

    Keep WordPress auto-updates enabled; older affected versions are fixed via a security release back to 3.7.37.

    WordPress auto-updates = enabled

Event History

Jan 6, 2022
CVE Published
via MITRE·11:00 PM
Data Sourced
via MITRE·11:00 PM
DescriptionSeverityWeakness
Data Sourced
via OSV·11:15 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-21663?

CVE-2022-21663 is a vulnerability in WordPress that allows users with the Super Admin role to bypass explicit/additional hardening through object injection.

2

What is the severity of CVE-2022-21663?

The severity of CVE-2022-21663 is high with a severity value of 7.2.

3

How can I exploit CVE-2022-21663?

We do not encourage or provide information on exploiting vulnerabilities. It is important to prioritize the patching or updating of affected software.

4

How do I fix CVE-2022-21663?

To fix CVE-2022-21663, you should update your WordPress installation to version 5.8.3 or higher.

5

Where can I find more information about CVE-2022-21663?

You can refer to the following resources for more information: <br> - WordPress Security Release: [Link](https://wordpress.org/news/2022/01/wordpress-5-8-3-security-release/) <br> - WordPress GitHub Security Advisories: [Link](https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-jmmq-m8p8-332h) <br> - HackerOne Report: [Link](https://hackerone.com/reports/541469)

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203