CVE-2022-21664: SQL injection in WordPress
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to lack of proper sanitization in one of the classes, there's potential for unintended SQL queries to be executed. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 4.1.34. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 6.1.9+dfsg1-0+deb12u1Fixed in 6.8.7+dfsg1-0+deb13u1Fixed in 6.8.12+dfsg1-0+deb13u1Fixed in 7.1.4+dfsg1-1 - Upgrade
Upgrade
debian/wordpressto a version that resolves this vulnerability.Fixed in 5.8.3+dfsg1-1 - Upgrade
Upgrade
WordPressto a version that resolves this vulnerability.Fixed in 5.8.3 - Configuration
Keep WordPress auto-updates enabled.
WordPress auto-updates = enabled
Event History
Frequently Asked Questions
What is CVE-2022-21664?
CVE-2022-21664 is a vulnerability in WordPress that allows for unintended SQL queries to be executed due to a lack of proper sanitization in one of the classes.
What is the severity of CVE-2022-21664?
The severity of CVE-2022-21664 is high with a CVSS score of 8.8.
Which versions of WordPress are affected by CVE-2022-21664?
WordPress versions 5.0.15+dfsg1-0+deb10u1, 5.0.19+dfsg1-0+deb10u1, 5.7.8+dfsg1-0+deb11u2, 6.1.1+dfsg1-1, and 6.3.1+dfsg1-1 are affected by CVE-2022-21664.
How can I fix CVE-2022-21664?
To fix CVE-2022-21664, you should update WordPress to version 5.8.3 or newer.
Where can I find more information about CVE-2022-21664?
You can find more information about CVE-2022-21664 at the following references: [Link 1](https://github.com/WordPress/wordpress-develop/commit/c09ccfbc547d75b392dbccc1ef0b4442ccd3c957), [Link 2](https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-jp3p-gw8h-6x86), [Link 3](https://lists.debian.org/debian-lts-announce/2022/01/msg00019.html).