CVE-2022-22816: Medium severity Python Pillow vulnerability

Published Jan 7, 2022
·
Updated

pathgetbbox in path.c in Pillow before 9.0.0 has a buffer over-read during initialization of ImagePath.Path.

Affected Software

19 affected componentsFixes available
pip/pillow<9.0.0
9.0.0
Python Pillow<9.0.0
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Debian Debian Linux=11.0
debian/pillow<9.0.0-1
9.0.0-1
debian/pillow<9.0.0-1
9.0.0-1
debian/pillow<9.0.0-1
9.0.0-1
debian/pillow
9.4.0-1.1+deb12u111.1.0-5+deb13u411.1.0-5+deb13u312.3.0-113.0.0-1
alpine/py3-pillow<8.4.0-r2
8.4.0-r2
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0
alpine/py3-pillow<9.0.0-r0
9.0.0-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/pillow to a version that resolves this vulnerability.

    Fixed in 5.4.1-2+deb10u3Fixed in 8.1.2+dfsg-0.3+deb11u1Fixed in 9.4.0-1.1Fixed in 10.1.0-1
  2. Upgrade

    Upgrade pip/Pillow to a version that resolves this vulnerability.

    Fixed in 9.0.0

Event History

Jan 7, 2022
CVE Published
via MITRE·12:00 AM
Data Sourced
via MITRE·12:00 AM
Description
Jan 10, 2022
Data Sourced
via NVD·02:12 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·02:12 PM
DescriptionSeverityAffected Software
Jan 12, 2022
Advisory Published
via GitHub·08:07 PM

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2022-22816?

CVE-2022-22816 is a vulnerability in the Pillow library, specifically in the path_getbbox function in path.c, which could result in a buffer over-read during the initialization of ImagePath.Path.

2

How does CVE-2022-22816 affect software?

CVE-2022-22816 affects the Pillow library versions before 9.0.0, as well as specific versions of the Debian Linux operating system.

3

What is the severity of CVE-2022-22816?

The severity of CVE-2022-22816 is medium, with a severity value of 6.5.

4

How can I fix CVE-2022-22816?

To fix CVE-2022-22816, update the Pillow library to version 9.0.0 or higher.

5

Where can I find more information about CVE-2022-22816?

You can find more information about CVE-2022-22816 on the NVD website and the official Pillow release notes for version 9.0.0.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203