CVE-2022-22822: Integer Overflow
addBinding in xmlparse.c in Expat (aka libexpat) before 2.4.3 has an integer overflow.
Other sources
expat (libexpat) is susceptible to a software flaw that causes process interruption. When processing a large number of prefixed XML attributes on a single tag libexpat can terminate unexpectedly due to integer overflow. The highest threat from this vulnerability is to availability confidentiality and integrity.
In storeAtts of xmlparse.c, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.
— OSV
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/expatto a version that resolves this vulnerability.Fixed in 0:2.1.0-14.el7_9 - Upgrade
Upgrade
redhat/expatto a version that resolves this vulnerability.Fixed in 0:2.2.5-4.el8_5.3 - Upgrade
Upgrade
redhat/xmlrpc-cto a version that resolves this vulnerability.Fixed in 0:1.51.0-8.el8 - Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.4.3-1Fixed in 2.2.6-2+deb10u2Fixed in 2.2.10-2+deb11u1 - Upgrade
Upgrade
redhat/expatto a version that resolves this vulnerability.Fixed in 2.4.3 - Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.5.0-1+deb12u2Fixed in 2.5.0-1+deb12u5Fixed in 2.8.3-1~deb13u1Fixed in 2.9.0-1~deb13u1Fixed in 2.9.0-1Fixed in 2.10.0-1 - Upgrade
Upgrade
alpine/expatto a version that resolves this vulnerability.Fixed in 2.2.10-r0 - Upgrade
Upgrade
alpine/expatto a version that resolves this vulnerability.Fixed in 2.2.10-r2 - Upgrade
Upgrade
alpine/expatto a version that resolves this vulnerability.Fixed in 2.4.3-r0 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 10:2022-09-01 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 11:2022-09-01 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 12:2022-09-01 - Upgrade
Upgrade
android/platform/external/expatto a version that resolves this vulnerability.Fixed in 12L:2022-09-01 - Upgrade
Upgrade
debian/expatto a version that resolves this vulnerability.Fixed in 2.4.3-1 - Upgrade
Upgrade
libexpatto a version that resolves this vulnerability.Fixed in 2.4.3
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is CVE-2022-22822?
CVE-2022-22822 is a vulnerability in the Expat library (libexpat) before version 2.4.3 that allows an integer overflow, leading to process interruption.
What is the severity of CVE-2022-22822?
The severity of CVE-2022-22822 is critical with a CVSS score of 9.8.
What is the affected software for CVE-2022-22822?
The affected software includes Expat (libexpat) versions before 2.4.3, as well as other packages and distributions listed in the vulnerability description.
How can I fix CVE-2022-22822?
To fix CVE-2022-22822, it is recommended to update Expat (libexpat) to version 2.4.3 or apply the provided patches or remedies for the respective packages and distributions.
Where can I find more information about CVE-2022-22822?
You can find more information about CVE-2022-22822 in the provided references: [link1](https://github.com/libexpat/libexpat/pull/539), [link2](http://www.openwall.com/lists/oss-security/2022/01/17/3), [link3](https://bugzilla.redhat.com/show_bug.cgi/show_bug.cgi?id=2044458).